Skip to main content

RFID Tag Troubleshooting Guide

If your RFID tags are scanning as unknown items, not scanning at all, or scanning inconsistently with reduced read range, follow the troubleshooting steps below to identify and resolve the issue.

When troubleshooting RFID performance, it’s important to isolate and test one variable at a time. This helps identify the root cause quickly and avoids masking the actual issue.


Issue: Tag is scanning as "Unknown"

This issue relates to scans displaying an SGTIN string (sgtin-96:511099.0001804.1) instead of product names

Possible Causes:

  • Product does not exist in Simple RFID
  • Mobile app product database is out of date

Troubleshooting Steps:

  1. Confirm that the product appears in the Products page of the web portal.
  2. If the product doesn't appear, try and reimport from partner system.
  3. If using Shopify:
  4. From the mobile app: Force Reload Products

Issue: Tags are not scanning at all

This issue relates to tags not showing up in a scan

Potential Causes:

  • Tag persistence is on
  • Tag is damaged
  • Tag not encoded properly
  • Tag is applied to/sitting on disruptive materials
  • Tags are bunched together closely and touching one another
  • Tag has a duplicate serial number

Troubleshooting Steps:

  • Wait 1 minute and then attempt to scan the tag again. If the scan is successful after waiting, the issue is likely tag persistence.
  • Scan on a neutral surface. If the scan is successful on a neutral surface the previous attempt likely has interference.
    • A neutral surface is any surface which is confirmed to not interfere with the RFID signal. To find a neutral surface, locate a confirmed working tag to scan on the surface to rule out interference.
  • Scan tags with EPC Read feature in the mobile app to scan the tags
    • Make sure that the EPC numbers are encoded correctly. If a value appears the tag is functioning, then continue to step 2.
    • If no EPC value appears, the tag may be damaged.
  • If items fail to scan when packed together closely, use "Density" scan mode to attempt to capture tags.
    • If many tags are bunched together closely, separate them and try to scan them.

Issue: Tag performance is reduced and/or inconsistent

Instances of this include tags not reading from the expected distance, or not reading from certain angles

Potential Causes:

  • Tags are placed in a disadvantageous location on the product, such as the bottom
  • Tags are shielded by metal or reflective packaging.
    • This can include other RFID tags, for example if two RFID tags are stacked on top of each other the tags may interfere with each other
  • Tags will not scan from an acceptable distance. For example if the tags normally scan from 10' away, however now scan from under 1'.

Troubleshooting Steps:

  • Confirm that there are no environmental issues relating to scans. Do the tags scan when applied to some items, but not others? Do tags lose performance when sitting on some materials? Is the read range affected or decreased?
    • Scan on a neutral surface. If the scan is successful on a neutral surface the previous attempt likely has interference.
    • A neutral surface is any surface which is confirmed to not interfere with the RFID signal. To find a neutral surface, locate a confirmed working tag to scan on the surface to rule out interference.